Supporting older versions of WordPress • Yoast

Spread the love


As soon as WordPress 5.3 comes out, Yoast will only support WordPress 5.2 and WordPress 5.3, and not versions before that. This means we’ll end our support for WordPress 4.9, which we’d kept alive for a little bit longer than usual to allow people to transition to WordPress 5.0 and the classic editor. I’d like to explain why we have this policy and why we’re deciding to go back to it.

Building software for WordPress can be incredibly complex. We work in a world where there are always a couple of versions of WordPress around. Next to that, plugins can do almost anything (which they do), which also means they can interfere with each other. Every site has a different combination of plugins, leading to tens of thousands of different combinations.

Modern code

At Yoast we pride ourselves in using the best tools available to build solutions for our users. With WordPress 5.2, the WordPress core team upped the minimum PHP requirement for WordPress from PHP 5.2 to PHP 5.6. We always want our software to work on the minimum requirements for WordPress, which means we could only use functionality from PHP 5.2 up until then.

Note: I know these version numbers and the fact that they’re so alike can become confusing. We’ve certainly had some confusion around that internally. I apologize for that in advance, but as you’ll understand, I can’t change these version numbers.

READ ALSO  Fixed: The Beginner’s Guide to Accessibility Testing

PHP is the language that most of the WordPress backend is built in. PHP 5.2 was released in 2006, while PHP 5.6 was released in 2014. As you can see, that’s 8 years apart, and 8 years is an incredibly long time on the internet.

By going back to our policy of only supporting the current and previous version, and thus only supporting WordPress 5.2 and 5.3, we allow ourselves to develop using PHP 5.6. Because we can use PHP 5.6 now, we can develop faster and more securely.

What does “support” mean?

When we say we don’t support an older version of WordPress it means we’ve stopped testing with it, and things are likely to break. It also means you won’t see Yoast SEO updates until you’ve updated your WordPress to a supported version.

My site doesn’t work with the classic editor

For a small portion of sites, I know this leaves them in limbo, which we hate. If you have a custom WordPress solution, built with old versions of plugins like Advanced Custom Fields (ACF), you might be “stuck”. Even though ACF has done an incredibly good job of migrating to Gutenberg, that might not “save” you.

While we think that sucks, we don’t really have any option for you other than to go to your website developer and explain them that this isn’t a state you want to stay in. You really should move to newer versions of WordPress. We will keep on supporting the Classic Editor for a few more years, so if they make it work with that, you’re good.

READ ALSO  Fixes and improvements • Yoast

I don’t see any Yoast SEO updates

There are a couple of different reasons why you can’t see Yoast SEO updates. As said above: if you’re on an old version of WordPress, you will not see them. So update your WordPress first. If that’s not the case, please reinstall the plugin, simply delete it and install the latest version manually. That won’t delete any of your data, don’t worry.

Go and update your site!

So, if you’re on an old version of WordPress, go and update. Of course, before doing anything like updating plugins or WordPress, always make sure to test and back up your site!



Source link


Spread the love